Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.180.1 Minor - Beta Improvements

Discussion in 'Change Log' started by Drui, Apr 20, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Drui Keen Update Guy Administrator

    Messages:
    1,356
    Hello, Engineers! This week’s update is a minor release that contains some smaller improvements as the team starts work towards the next major release once again. You should notice that because the last update was major, we created the ability to rollback to the most updated version of the previous major update 1.179 via the BETAS tab in Steam.
    One of the notable things in the works at the moment is higher quality and optimised tree LODs which will allow for denser forests while at the same time having higher frames per second on planets.
    The programmers are pursuing various slowdowns and performance drops in multiplayer while also working on optimising rendering performance and improving the visuals and lighting in the game. These tasks in particular are massively time-consuming and complicated, especially as we are developing our engine in-house on top of programming the game itself. But we really appreciate your continued support and patience as we work on these areas.
    Lastly, next Monday we will be streaming at 7PM CEST on the Keen Community Network over on Twitch. The first segment will be with Deepflame looking at Medieval Engineers and the game’s upcoming major release and then there will be a Q&A session with Marek and other members of the team here at KeenSWH.



    Fixes
    - fixed batteries and solar panels
    - fixed crash while spawning modded asteroid
    - fixed object states not updating when destroyed in multiplayer
    - fixed tools working at the same speed
    - fixed corrupted world file when using illegal characters for world name
    - fixed incorrect position of personal light after dying and respawning
    - fixed problems with selected blocks when player is dead
    - fixed ship grinder flare being too bright

    Hotfix 4/21/2017
    - fixed crash in HUD colors mod ( https://steamcommunity.com/sharedfiles/filedetails/?id=889485290 )
    - fixed crash when using area welder in XL industrial mod ( https://steamcommunity.com/sharedfiles/filedetails/?id=574145580 )
    - fixed crash in inventories
    - fixed spectator not working in survival with creative tools on
     
    Last edited by a moderator: Apr 21, 2017
    • Like Like x 10
  2. Replic TuaniOne Apprentice Engineer

    Messages:
    482
    FIRST

    Mwhahahahaha

    Also, nice basic assembler!
     
    • Late Late x 1
  3. Ed Frost Senior Engineer

    Messages:
    1,133
  4. I23I7 ME Tester Staff

    Messages:
    3,771
    Cannot kill the battery
    Cannot kill the family
    Battery is found in me
    Battery
    Battery

    * Headbangs in background *
     
    • Like Like x 3
    • Funny Funny x 2
  5. Timotei~ Apprentice Engineer

    Messages:
    190
    basic assembler. Interesting.
    Reworked survival hype: |------------------[]-|
     
    • Agree Agree x 1
  6. Forcedminer Senior Engineer

    Messages:
    2,198
    ♫ what's new pussycat? ♫

    and by new i mean what unintended feature is going to kill me this week...


    - fixed tools working at the same speed
    well thank f**k for that......happy about that.
     
    • Like Like x 2
  7. Nailbomb83 Trainee Engineer

    Messages:
    45
    - fixed ship grinder flare being too bright
    Yeah!!!
     
    • Agree Agree x 1
  8. captainbladej52 Apprentice Engineer

    Messages:
    220
    If that assembler is only taking up 1 block, even for a less powerful version than the bigger brother, the hype is real for me as I may just start using them in some of my larger ships to create repair parts. The hype is real for these upcoming features.

    On the bug front I'm hoping you guys have some info on a couple bugs that have been out there as of a couple updates ago.

    1: spawning blueprints you've used previously with no issue may now be crashing the game. have a few of my blueprints that never gave me fits before that are now crashing my game.
    2: Projectors causing LCD panels to flicker between displayed message and the offline message when the projector is being used to conduct repairs. have seen a few instances where my LCDs flicker between a displayed message and the offline setting which can be a bit disorienting.
    3: highly populated words crashing to desktop when attempting to interact with a control panel or after 5 minutes. Been having several issues with my more highly populated worlds where they've been crashing to desktop if I try to interact with a control panel. If it doesn't crash when I use the control panel it will crash when I attempt to spawn or despawn something, or will crash after about 5 minutes.

    The LCD panel issue doesn't bother me as much as the crashing does but just curious if Keen has any possible info on any of this stuff they can share.
     
    • Agree Agree x 2
  9. Harrekin Master Engineer

    Messages:
    3,077
    So...

    Is there ever anything new going to be added to the gameplay?

    Tree LOD's are great and all but seriously...

    Just answer it with a yes or no, no need to be specific but the gameplay is SORELY lacking and it seems "polish, fix and release" is the only priority.

    Sure, it'll work eventually...but then what? The gameplay just isn't there.

    Just let us know, the stringing along is getting extremely irritating.
     
    • Agree Agree x 6
    • Disagree Disagree x 2
    • Late Late x 2
  10. Mr Engineer Apprentice Engineer

    Messages:
    467
    Like the update. More FPS is always welcome here!! Thats one awesome space elevator though. I like the Assembler idea, something you'd expect to see in an escape pod or something like a small shuttle.
     
    • Agree Agree x 1
  11. captainbladej52 Apprentice Engineer

    Messages:
    220
    They could be put into an escape pod or perhaps added to larger ships as a means of creating repair parts in an emergency situation. At least I intend to integrate some of them for that purpose.
     
    • Agree Agree x 2
  12. mhn23 Trainee Engineer

    Messages:
    6
    would be cool to be able to build a basic assembler from ore or have a basic refinery from ores, then we just need a way to collect ores with nothing to be able to start from 0. But i assume the new dropPod will have the new assembler and maybe a new basic refinery with tools in it (hello emyprion). Nevertheless a nice start playing planetary, tho i wonder what happens to the starts in space.
     
  13. Legas Trainee Engineer

    Messages:
    51
    I'm skeptical, can anyone confirm? I don't have the game installed at the moment.
    I find it weird that it was such a gamebreaking bug and it was not even mentioned in the video.

    I like the 'basic assembler' as it hints a more developed crafting depth/progression, BUT I hate the model.
    Why everything must look like a box/cargo/conveyor block? Can't it have any form other than a box/cube? Too many functional blocks look like cubes, I don't get the reason for this.

    In comparison, gyros, gravity generators and warheads look awesome just because they aren't cubes.
     
    • Agree Agree x 6
  14. theorytard Trainee Engineer

    Messages:
    37
    My only request is that when you use a community build can you please put a link to the workshop page
     
    • Agree Agree x 1
  15. The MoSS 2 Apprentice Engineer

    Messages:
    159
    - fixed batteries and solar panels

    I hope it works. I'm playing on server with scarce resources mod (closest uranium is on Alien Planet) and I hate seeing "available - 100kW, output - 0W" when recharging a single small battery on my tiny ship.
     
    • Agree Agree x 3
  16. Ivan Trunov Trainee Engineer

    Messages:
    16
    LCDs don't need projector to flicker, they can do it themselves - https://forum.keenswh.com/threads/1-178-to-1-180-lcd-panels-dim-randomly.7393822/
    Also LCDs cause this bug, still. is not fixed since the last patch - https://forum.keenswh.com/threads/01-180-0-major-eye-adaption-flicker.7394205/

    For AMD users game seems really broken since 1.180.0...
     
    • Agree Agree x 1
  17. jemccro Trainee Engineer

    Messages:
    97
    I believe the video was actually made last week before Xocliw went on vacation, so details are going to be absent.
    --- Automerge ---
    They likely use the cube shapes for most blocks to make things air-tight if there is not a row of armor blocks between the inside and outside of the ship/station.
     
    • Agree Agree x 4
    • Disagree Disagree x 1
    • Funny Funny x 1
  18. Igneus Tempus Trainee Engineer

    Messages:
    4
  19. DigitalStone Apprentice Engineer

    Messages:
    239
    The game is still in serious disco-mode. Did someone take some magic pill? :p

    --EDIT--
    Hotfixes have dropped by, very nice. But i still hold foot in the magic shrooms... ehh pills... whatevs :)
     
    Last edited: Apr 22, 2017
    • Funny Funny x 2
    • Agree Agree x 1
  20. The Chuggernaut Trainee Engineer

    Messages:
    18
    Does anyone have a link to that awesome Space Elevator?
     
  21. odizzido Junior Engineer

    Messages:
    602
    fixed solar/bats.....madness. must check.
     
  22. Dwarf-Lord Pangolin Senior Engineer

    Messages:
    2,596
    Well, this is a voxel-based game. You kind of answered the question yourself; they're functional blocks, so the normal shape is for them to be block-shaped.

    And TBH, I think the more cube-shaped blocks look better. Rounded shapes leave unsightly gaps and holes in things.
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  23. Zooltan Trainee Engineer

    Messages:
    4
    "-fixed batteries and solar panels"

    YES!! Oh how i have been longing to see those words!
     
    • Like Like x 1
  24. Home Trainee Engineer

    Messages:
    22
    The "elevator" really shows that ropes are much needed in this game. There is absolutely no way to build real elevators at the moment and pistons don't work at all, you cannot even connect multiple pistons without exploits.
     
    • Disagree Disagree x 4
  25. Zachary Fitch Trainee Engineer

    Messages:
    43
    Did you guys at least find out what was causing the lighting issues when using LCD's? Also the inventory access bug would be a really nice one to see fixed... I didn't see either on the ChangeLog so maybe you guys are working on it?
     
    • Agree Agree x 1
  26. ATMLVE Apprentice Engineer

    Messages:
    102
    What blasphemy is this? Just place one piston on the end of another one. Also, you argue that pistons don't work at all, and then you also say that they should add rope? Yes, instead of fixing pistons, just ignore them and add rope, which will work perfectly on the first try.
     
    • Funny Funny x 5
    • Agree Agree x 2
  27. Forcedminer Senior Engineer

    Messages:
    2,198

    I haven't seen anything clang related in medievil engineers due to the ropes yet.

    wheres in space engineers one single piston is enough to rip a spaceship to pieces.
    like 1 tiny tiny tiny TINY bit of resistance and the entire thing just explodes uselessly instead i don't know slowly down due to resistance...there is no resistance just explosions
     
  28. KingdomBragg Junior Engineer

    Messages:
    544
    Thanks :)
     
    • Like Like x 1
    • Friendly Friendly x 1
  29. I23I7 ME Tester Staff

    Messages:
    3,771
    Hey guys,


    Flickering shadows are being looked into. Just wanted to let you know. We already know it's related to some degree to LCD panels.
     
    • Like x 9
    • Friendly x 3
    • Disagree x 2
    • Agree x 1
    • Informative x 1
  30. ZinuxGamer Trainee Engineer

    Messages:
    55
    if that basic assembler is a all-in-one unit, as it can refine and assemble at a slower rate than its big brothers to enhance progression in the early game .... thats an I idea I've come up with and dicussed in various places :)
    --- Automerge ---
    I got a scarce resources SP 'offline' world with no sun rotation which after around 4-5 nights of play decided it wasn't going to output anything at from from solar, so got stuck in the batteries will just run out situation .....
    Previous to that it had the other weridness for a few days where lets say you got plently of batteries, 3MW of solar, lets say 0.2MW of usage on the grid ... the solars and batterys will only charge at 2.8MW, with the batteries outputing at 0.2MW....

    I've just loaded up the world and its autolcd2 is reporting this:
    Solars: 3.8 MW / 3.8 MW
    Batteries: (IN 3.8 MW / OUT 4.5 MW)
    Stored: 4.1 MWh / 8.6 MWh
    Output: 4.5 MW / 34.6 MW
    Input: 3.8 MW / 34.6 MW
    Total Output: 8.3 MW / 38.4 MW

    That looks a lot better right? :)
     
Thread Status:
This last post in this thread was made more than 31 days old.