Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 02.057 – Item icons on HUD, Inventory sizes

Discussion in 'Change Log' started by Drui, Feb 23, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Drui Keen Update Guy Staff

    Messages:
    1,401
    Summary
    In this week’s update we are changing how interaction with items is shown and also offering a couple of sizes for your inventory.
    If you pick up any item to your inventory, it will show you the icon of that item and its amount on your HUD. You can also choose the size of your inventory in the settings menu. It can be set to default, triple and ten in size. Yes, you can carry ten times more items this time around.
    In creative mode the inventory is unlimited in size. This applies only to your character and not to other containers in the game.
    And as always, we applied bug fixes to the game.



    Features
    - Item icons on HUD
    - Inventory sizes

    Fixes
    - fixed client crash when server was disconnected while MyGuiScreenInventory is displayed on client
    - player is now unable to build on objects which are being manipulated at the moment
    - fixed a few memory leaks in the renderer
    - fixed outlines getting drawn over grass again
    - fixed bug that allowed particular zones not to be audible when jumping over them
    - attack animation is now not interrupted by other animations (running, jumping, rotation, etc)
    - fixed bigger inventory bag bug
    - added sound of flying catapult stone to the game
    - improving tree falling sounds
    - changing the starting date in all scenarios to 7:00 AM from 9:00 AM
    - fixed crash in CreateReplicable
    - fixed strange looking and dysfunctional rope drum
    - fixed battle music playing most of the game time without any reason
    - fixed crash in audio distance sound system
    - changed hit reporting to have an additional sprite appear and fade out rather than enlarging and coloring the existing one
    - added tool hit sounds for different surfaces
    - fixed head angle having a "Not a Number" sometimes
    - fixed a crash on the client when pasting a blueprint in the air
    - fixed a client crash in Sandbox.Game.Entities.MyFloatingObject.GetPhysicsShape
    - fixed tool hit sounds against grass
     
    • Like Like x 8
  2. Thales M. Junior Engineer

    Messages:
    999
    Early patch :)
     
  3. Goomboss Trainee Engineer

    Messages:
    14
    We really need those features. I still can't play the game with updated nVidia drivers because I see everything overbrightened, but this is irrelevant: we finally have item icons on HUD. Another exciting update, Keen!
     
  4. Bloody_Kain Apprentice Engineer

    Messages:
    277
    What Card do you have?
    I had the same Problem with my GTX 560 TI, but now with my new GTX 750 TI this Bug is gone.

    I think this is an Engine Bug that maybe have something to do with older NVIDIA Cards?!
     
  5. Thermonuklear Junior Engineer

    Messages:
    610
    I really wish the player-only inventory size modifier finds its way to SE as well...
     
  6. Stori3D Past Productions Apprentice Engineer

    Messages:
    298
    If the battle music problem is really fixed, that is a very nice fix! I'm eager to get into the game and check this out.
     
  7. Goomboss Trainee Engineer

    Messages:
    14
    GTX 560 Ti, exactly.
     
  8. Mr Engineer Apprentice Engineer

    Messages:
    467
    Looking good! I should play this more often.
     
  9. Stori3D Past Productions Apprentice Engineer

    Messages:
    298
    Nope. Battle music still plays after about 2-3 songs. Still broken. Still can't enjoy the soundtrack. Boo.
     
  10. Ghostickles Senior Engineer

    Messages:
    2,074
    Still bright white for my 600 series NVidia card also, apparently the cause is with the tone mapping, if there is not going to be a fix for some more time yet can we please get something to toggle this off in all game modes? Pretty please? I can only imagine a new players horror first time they try this game with the White Light problem. Bad bad bad.
     
  11. Stradosphere Trainee Engineer

    Messages:
    40
    Can any of the guys with "bright white" issue can post a screenshot please ?
     
  12. Goomboss Trainee Engineer

    Messages:
    14
    You seriously asked for a white screen screenshot? Btw, enjoy. Because I can't.
     
  13. Stradosphere Trainee Engineer

    Messages:
    40
    Yes of course i was serious because i have not encountered that kind of problem yet neither on Nvidia nor Amd.But you were right, that brightness is just melting my eyes :(
     
  14. Thermonuklear Junior Engineer

    Messages:
    610
    I have the same card and setting tonemapping off via the F12 debug menu made the white light problem go away.
     
Thread Status:
This last post in this thread was made more than 31 days old.