Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 1.184.1 Minor - Beta Improvements

Discussion in 'Change Log' started by Drui, Sep 21, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Sid_raptor Trainee Engineer

    Messages:
    14
    hooboy! Now my controls are all messed up! Forward and Backwards is fine but mouse left and right now rolls meas Q and E used to before. A and D now turn me left and right like arrow keyds.....is it just me or is it this update?reverting to previous version for now...............
    --- Automerge ---
    also unrelated,but i dont know where to post this,but on my forumprofile, why the hell does it show the Syrian flag instead of Tanzania???
     
  2. Logi Apprentice Engineer

    Messages:
    170
    Thank you for adding the half block for small grid :)
     
    • Like Like x 3
  3. Spets Master Engineer

    Messages:
    3,214
    MRW I heard they added the small grid variant for half blocks
    [​IMG]
    :carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton::carlton:
     
    • Funny Funny x 3
    • Agree Agree x 1
  4. Sid_raptor Trainee Engineer

    Messages:
    14
    also unrelated,but i dont know where to post this,but on my forumprofile, why the hell does it show the Iraqi flag instead of Tanzania???
    Never mind,Reinstallingseems to have fixed the problem....still irked about the flag though
     
  5. sepen_ Trainee Engineer

    Messages:
    52
    Whoever reduced the inventory volume of Large Tubes, 1-1-1 says thank you! :)
     
    • Agree Agree x 4
  6. wagner Apprentice Engineer

    Messages:
    101
    Thanks for that, it was a game breaker for me. Had to go to SEToolbox to remove buged blocks all the time.
     
  7. jandraelune Apprentice Engineer

    Messages:
    218
    • fixed inability to control a Remote Control block shared with you
    • fixed problem where Take Control button was not working properly
    ^^^ Still broken on both a DS and Local world on Planets with no mods. Turret Control was fixed for In Space.
     
  8. Thrak Junior Engineer

    Messages:
    536
    Projectors are still buggy, including spontaneously appearing (even though the block is off) when a ship is damaged and blocks are blown free (creating a new grid).
     
  9. I23I7 ME Tester

    Messages:
    3,827
    That one is reported but is not fixed so its not mentioned in the change log :)
    --- Automerge ---
    Thanks reported!
     
  10. rexxar Senior Engineer

    Messages:
    1,532
    PSA: If your world size blew up due to the block group bugs, this update fixes the issue. Once you load and re-save your world, the size will go back to normal.
     
    • Like Like x 1
  11. Syncaidius Junior Engineer

    Messages:
    824
    [​IMG]
     
  12. darth_crunchus Apprentice Engineer

    Messages:
    239
    Thanks for all the hard work on this game, devs. It's been a bumpy ride at times, but I know that wherever this ends up, it's going to be great!

    Oh, one other thing, before I go -- there's still an issue with the hand tool skin application; if you A) reload, B) rapidly switch between tools, or C) just randomly during the course of game play, the tools will revert back to the default skin. The reload thing is not always repeatable, though, so, I don't know if that counts.
     
    • Friendly Friendly x 1
  13. Darian Stephens Trainee Engineer

    Messages:
    43
    Have you guys noticed the issue where, if your grid entirely loses power, conveyor connections won't be reestablished until you reload the world?
    It really puts a damper on scraping by with solar power; you need a battery running all night just so you don't have to restart the game in the morning.
     
  14. JJayzX Trainee Engineer

    Messages:
    25
    What was in today's update? Seems it was put out more quickly than post updated, oops.
     
    • Agree Agree x 2
  15. aetherbeetz Trainee Engineer

    Messages:
    10
    Turrets seem to be back to their old habits of targeting owned grids, as in: turrets that are owned by player A will begin targeting grids that are ENTIRELY owned by player A after enough time (enough = about an hour). In every instance, the turrets were set to only target meteors. Reloading the world seems to fix this for about another hour.
    This combined with a lack of a UI-based way of adjusting autosave intervals in SP has led to some hair-pulling moments. Freezing the game every five minutes is getting old but every now and then I get a backup save that can protect me from the game's own flaws, so ehhh...

    Also just to repeat for emphasis: Character Toolbar Presets. I would love to go and check out many different servers but the lack of this seemingly-easy-to-implement tool means I, and of course anyone else, would have to set up my toolbar every time. Even just a couple "states" would suffice. And if a saved state is loaded that includes mods that are not active in the world, just make them that greyed out box. The new HUD has room, and if not, I doubt anyone needs an indicator on the HUD to tell them whether they're placing a small grid or large grid block so....

    Parachutes are fun and useful. Half-blocks on small grid are very useful. And sim-speed, FPS, and overall stability have noticeably improved. Awesome work. Not salty, just getting shot by my own turret for no reason for the umpteenth time in 4,000+ hours of play hits a nerve.

    edit: also the inventory size multiplier filter for the server screen appears to not be functioning.
     
    Last edited: Sep 26, 2017
    • Like Like x 1
  16. I23I7 ME Tester

    Messages:
    3,827
    Hello,

    Turrets target neutral and enemy grids. They do not target grids that are owned by the player or owned by allies of the player. So the issue only appears after an hour? I set up two turret grids owned by me and waited for an hour and did not see them start to target each other.

    Thanks for the reports!
     
    • Friendly Friendly x 1
  17. posthy Apprentice Engineer

    Messages:
    120
    I noticed something like this, but didn't have to reload the whole savegame, removing and rebuliding a single conveyor block from the network fixed the particular section (between conveyor junctions or functional blocks).
     
    • Agree Agree x 1
  18. KissSh0t Master Engineer

    Messages:
    3,695
    @I23I7

    Interesting bug.. closed the game, then about 5 minutes later went to close steam and it come up with this message.

    [​IMG]

    And then checked processes and saw that SE was still running despite closing it.

    [​IMG]
     
  19. Darian Stephens Trainee Engineer

    Messages:
    43
    Maybe, but having to deconstruct and rebuild every block which acts as a conveyor junction would be more tedious than just reloading the game.
     
  20. Asylumdown Trainee Engineer

    Messages:
    57
    Was there anything in the most recent hot fix that could have caused grids to suddenly move? Last night I was half way through an ascent from a planet to my orbital station when the game suddenly started freezing and jittering so badly it took several keystrokes to bring up space master.

    Went through the entity list, and that orbital station I was headed towards (including a capital ship docked to it) was suddenly partially embedded in an ice lake on the surface 50 km away. It was doing that wild jittery thing that happens when you convert a station embedded in a voxel to a ship. Had to remove the grid from the world to make the game work properly again.

    The station had been 6 km outside the edge of the gravity well, and it was fully intact on the ground, so it didn’t somehow fall.
     
  21. Stardriver907 Master Engineer

    Messages:
    3,368
    This used to happen to me a LOT about six months ago. Game would still be running even though you closed it. Hasn't happened to me recently, though, so I can't tell you why it happened :(
     
  22. posthy Apprentice Engineer

    Messages:
    120
    Well, I play in creative mode with a bunch of mods, so for me loading a world can take longer then renew a couple of blocks :)
     
Thread Status:
This last post in this thread was made more than 31 days old.