Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Welders not welding valid projector blocks.

Discussion in 'Bug Reports' started by Noy, May 29, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Noy Apprentice Engineer

    Messages:
    112
    For some reason since the last hotfix, my tower builder has stop being able to build any blocks. Note: the projector and welders are on the same grid but that didn't stop it from working before. It just sits there and pretends there's no blocks to/it_can weld. Also this bug can potentially cause problems for self repairing builds as well.
     
  2. kittle Senior Engineer

    Messages:
    1,086
    I had the same problem when trying to weld a small ship.
    my welding wall would only weld the cockpit... no armor or thruster block. but I was able to place the blocks by hand. Once I placed the wireframe blocks, everything went fine.
     
  3. Don Jacobs Junior Engineer

    Messages:
    657
    I've noticed it randomly using the a version of the Repair Drone from Mission 2 and a projector projecting the station it's attached to. Doesn't happen with all blocks, just on occasion.
     
  4. Mauzen Trainee Engineer

    Messages:
    74
    Just had the same problem. Welded half of the projection without any problems. An airtight hangar door then smashed my cockpit, and after rebuilding it I couldnt weld any projected blocks at all in the ship. Using the hand welder still works though. Game restart/projector rebuild/etc cant fix this, is there any way to get it back to work again?

    Edit: When switching to creative mode it is working, but when going back to survival it still doesnt weld.
     
    Last edited: Jun 3, 2015
  5. Aequoris Trainee Engineer

    Messages:
    20
    I also am seeing this issue.
     
  6. Mauzen Trainee Engineer

    Messages:
    74
    Even copying the half-done projected ship to a fresh new world cant fix it.

    I finally fixed my problem this way:
    Switch mode to creative (make sure to turn off conveyors etc so items dont get deleted afterwards)
    Grind down the hangar door (which caused my problem originally)
    Weld some a few projected blocks
    Switch mode back to survival

    Im pretty sure there are easier ways, but this I didnt feel like experimenting even more.
    Still not sure if this was the general projector problem that the other guys here have, or if this was specifically caused by the hangar door smashing my cockpit while welding
     
  7. t]X[n Naz Trainee Engineer

    Messages:
    5
    So I'm having this very same issue, is there no way to fix it without going into creative?
     
  8. Noy Apprentice Engineer

    Messages:
    112
    For me the issue is IN Creative as well. From what I can tell, something in the code isn't being cleared or updated correctly (probably in an attempt to improve game performance.)
     
    Last edited: Jun 4, 2015
  9. Phand Master Engineer

    Messages:
    9,650
    Hi,

    could please someone send me the map where the problem is occurring? I will check it out. Thank you.
     
  10. Noy Apprentice Engineer

    Messages:
    112
    world file here: https://www.dropbox.com/sh/dd3uqve7ag69z4g/AACjuH-j0R9u3oo7b9NxwzD9a?dl=0

    the controls are pretty straight forward and should all be in the cockpit.
    On projector, On welders, let it finishing building, Off welders, Off merge Block, covert to ship, fly slowly up a bit, On merge, keep flying till it snaps into place, start from step one.
    eventually, if not right away, problems start to arise.
     
  11. t]X[n Naz Trainee Engineer

    Messages:
    5
    My issue is as simple as:

    1. Turn on projector and select blueprint
    2. Server freezes for a few seconds, and nothing loads on the projection
    3. Turn projector OFF and then ON, projection shows up
    4. Weld on any block that is adjacent to the platform and nothing happens
     
  12. moomin Trainee Engineer

    Messages:
    84
    Since the other topics regarding this problem aren't as "detailed" i'd like to bump this post by saying i have the exact same problem.

    I've built something in creative

    took that blueprint to survival
    projected it
    welded it

    Went back to creative,

    updated my build
    saved the blueprint (tried a lot; same name, name with version number, totally different name)

    Went back to survival

    Projected the blueprint (tried the just buildable projection and entire projection)
    Here it kinda went screwy as well though. Sometimes it'd immediatly project,.. sometimes it'd not and i'd have to switch it off and on.
    Also when i quit the game it 9 times out of 10 doesnt keep the projection.

    Can't weld any of the new blocks.

    I can however grind already placed blocks (after which a projected weldable block appears) and weld that projection. I can not weld any projections that came from the same projection that'd for example connect to that block i just grinded and rewelded.




    Emotion:
    If i had the symetry tool in survival i'd basicly not have this problem cuz then i'd just place the framework :p
    Also this kinda bumms me out because i have ships welding my projection while i fiddle around in single player doing the design part. Building big stuff in survival!! huzzah! :D
     
  13. moomin Trainee Engineer

    Messages:
    84
    Is there an max to the amount of blocks a blueprint can handle?

    Also another observation;

    I've exported my creation with SEtoolbox (Without owner) to a sbc file.
    Created a new world
    deleted all projectors on the creation
    Imported the creation.
    Created a blueprint of this creation.

    Now the funny part;

    I can still only weld(weld/place) the original blocks of the very first blueprint but only if i grind them first. Not any of the added blocks not even after grinding them first....
     
  14. RyansPlace Apprentice Engineer

    Messages:
    210
    I had a problem with some welders randomly change ownership. Be sure to check that as they may not turn on when a timer triggers them to otherwise.
     
  15. Lt. Yankee Apprentice Engineer

    Messages:
    296
    At some point building from projector or not, i cant place a block even if it shows green light.
    So to fix it i must grind that empty space and then weld it again.
    When u grind that empty space where the block should be u can see inventory is filling with materials
     
  16. Immersive Apprentice Engineer

    Messages:
    122
    Any news on this report? I too am having an issue with this.

    When using small projected blueprint:
    Small and Large ship welders don't reliably "create" blocks, but are still capable of "welding" them once created with the hand welder.
    I've found that I can occasionally create the blocks on the edge of the welding dummy. Never inside the dummy (if that makes sense).
    However, this is still inconsistent and I can't work out why.
     
  17. DS_Marine Apprentice Engineer

    Messages:
    494
    This is happening in current version 1.96.14 (to the OP, "since the last hotfix" doesn't make sense if you don't put the current version for you)
    There's a desync where the block gets put in the server but not in the client. As others have pointed out, you can grind the invisible block and then try to weld it again.
     
  18. scorpnoire Apprentice Engineer

    Messages:
    142
    We found out on our DS, that any ship containing a projector block activated and/or loaded with a blueprint beeing blueprinted leads to such a behavior (need an extra on/off in the projector until it appears, can't weld any blocks etc.).
    Removing said projector before blueprinting the ship will get you a fine working blueprint again.

    Though I seem to be unable to weld blueprints or rather set the highlighted blocks with my small welder ship. I have to set the blocks by hand, can weld them with the shp afterwards.
    Welders have the needed ressources, are not clogged up and I tried different angles and distances already.

    MP, small ship welder, Win7 64 bit Versions 1.094-1.096 atm.
     
  19. WraithLeader1 Apprentice Engineer

    Messages:
    414
     
  20. WraithLeader1 Apprentice Engineer

    Messages:
    414
    At work, I'll send the world after.
     
  21. wagner Apprentice Engineer

    Messages:
    101
    I know this is very old topic, but I am having the same problem in the current version, any news about it ?
     
  22. I23I7 ME Tester

    Messages:
    3,827
    You need be more precise in your reports otherwise there is not point on reporting it.

    Usually steps to reproduce to see the issue are enough.
     
Thread Status:
This last post in this thread was made more than 31 days old.