Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 0.6.2 Patch 1 - The Patchening

Discussion in 'Change Log' started by Drui, Jan 16, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Drui Keen Update Guy Administrator

    Messages:
    1,356
    Hello, Engineers!

    This week we have a small patch with important fixes for you guys. We addressed all the new crashes from the major release. Additionally, the server browser works properly again with the new Steam SDK. We closed a pretty nasty exploit with the crossbow that was allowing people to shoot super fast bolts, now it goes through the server for validation. Finally, we now drop block items one block at a time. This prevents accidental explosions of planks if someone dropped several stacks of planks at once.

    Enjoy the update, and see you next week!

    distr2.jpg

    General improvements:
    - The server browser now displays all servers correctly again.
    - Changed the way the crossbow works internally to prevent an exploit. (Thanks Replicant for the report)
    - Block items no longer drop as a whole stack, now they drop one at a time.
    - Balanced timber cost for horizontal mechanical transmission.
    - Assigned the correct LOD models to the deer pelt.
    - Log wall with shutters now has proper physical material assigned to it.
    - Blank scrolls can be placed into the bookshelves.
    - Crafting stations that require fuel now start to process the queue once fuel is inserted and lighted.
    - Modders can now access the projectiles to implement their own ranged weapons.
    - Modders can now access the active camera to add their own camera effects.

    Crash fixes:
    - Killing characters now no longer crashes the game.
    - Medieval Master's Grid trash removal no longer crashes the server when it deletes all grids.
    - The server browser no longer crashes when a server reports an invalid version.
    - Plow blocks no longer crash the server when a player leaves the region while the plow block is still moving.
    - AI spawning no longer crashes the server when a player leaves the region while the AI is spawning.

    Enjoy!
    Keen Software House team
     
    • Like Like x 6
    • Informative Informative x 1
  2. Ed Frost Senior Engineer

    Messages:
    1,133
    YAAAAAAAAAAAAAAY
     
    • Friendly Friendly x 2
    • Like Like x 1
  3. I23I7 ME Tester Staff

    Messages:
    3,777
    :tu:
     
    • Friendly Friendly x 1
  4. CptTwinkie ME Asst. Producer Staff

    Messages:
    4,253
    Ed, you must have a hole in your desk where the F5 key is
     
    • Agree Agree x 2
    • Funny Funny x 2
    • Friendly Friendly x 1
  5. Ed Frost Senior Engineer

    Messages:
    1,133
    im just quick enough to go to the forums after the emails out... or i check at precisely the right moment... i aint trying
     
  6. Cetric Junior Engineer

    Messages:
    624
    No explosions of planks in ME? Lord Clang will be not amused. The ME team is already much, much short on devotional explosions to him, and now THIS! :D
     
    • Funny Funny x 3
    • Agree Agree x 2
  7. Sanfard Apprentice Engineer

    Messages:
    108
    Now we can create rocket launchers!
     
  8. MorshuArtsInc Apprentice Engineer

    Messages:
    138
    Ooooooooooooh!
     
  9. KingdomBragg Junior Engineer

    Messages:
    544
    Thanks as always :)
     
  10. Ghostickles Senior Engineer

    Messages:
    2,070
    Super happy nice fixes!
    Thanks KEEN!!
    :)
     
  11. md34 Trainee Engineer

    Messages:
    5
    You need to add one more line to the crash fix section.
    - Now rather than crashing after 5 minutes, we crash on startup to save you the time!

    Post update i can't even startup.
    --- Automerge ---
    Replying to my own post...

    Found the following in the vragerender dx11 log.

    2018-01-22 12:44:36.995|Render thread> Exception occurred: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
    at SharpDX.DXGI.Factory.MakeWindowAssociation(IntPtr windowHandle, WindowAssociationFlags flags)
    at VRageRender.MyRender11.CreateDeviceInternal(IntPtr windowHandle, MyRenderDeviceSettings settings)
    at VRageRender.MyRender11.CreateDeviceInternalSafe(IntPtr windowHandle, MyRenderDeviceSettings settings, MyRenderExceptionEnum& exceptionType)
    2018-01-22 12:44:36.995|Render thread> CreateDevice failed: Disposing Device


    Could this be something?

    I updated to latest nvidia drivers, still no dice.
     
  12. Ed Frost Senior Engineer

    Messages:
    1,133
    *sneaks out of class to crawl onto the forums* UUUUUUUUPDAAAAAAATEEEEEEEE *sneaks back into class*
     
    • Funny Funny x 1
  13. md34 Trainee Engineer

    Messages:
    5
    Replying to my own post again. The 0.6.2 patch 2 update seems to have fixed this. Thanks :)
     
Thread Status:
This last post in this thread was made more than 31 days old.