1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. The forum will be closing soon permanently. Please read the announcement here

    Note: User registration has been closed. We do not accept any new accounts.

What A FREAKING MESS!

Discussion in 'Bug Reports' started by Buzzed Bear, Nov 23, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Buzzed Bear

    Buzzed Bear Apprentice Engineer

    Messages:
    275
    Howdy Devs!

    Firstly, THANK YOU for all the work you guys have done over the last couple years on this game. It is the single best investment I have made on Steam and continues to bring me hours upon hours of fun... and sometimes frustration.

    Here is the situation.

    Since the last update with all the physics re-works, I have been massively assaulted by the so called "Klang".

    I am trying to make a ship printing setup where the welders are situated on a small grid movable sled that goes forward and backwards on a "track" as the welders are moved up and down... nothing fancy. I also have to be clear here... I have NEVER had an issue with pistons and rotors before this update... at least NOTHING CLOSE to the issues I am having now.

    I built the sled, it moves back and forth without issue, the pistons I use to center and hold the unit in place have no issues, the pistons I use to raise the unit off the wheels work with no issue. However, once I start adding pistons to the base of the unit which hold the welders, all bets are off.

    Chapter 1
    I have 15 pistons grouped into rows of 5 - making 5 "Arms" with 3 Pistons on each arm. Each group is labelled as Upper, Middle, and Lower. After placing the first 5, my issues began. I selected the group and clicked on the shared tensor button... results - BOOM. The whole sled exploded and was launched into the air and landed couple hundred meters from my base... Reload.

    Chapter 2
    Still with only 5 pistons grouped, I set the shared tensor one by one. No Klang. I extend the 5 pistons (and fully extended there is about 10m between the end of the piston and the next block). Result - BOOM! the sled explodes again. Reload

    Chapter 3
    I decide to not use the Shared Tensor and the pistons raise and lower with no problems. I add the second row of pistons, leave the shared tensor OFF. Both sets of 5 pistons extend and retract with no problems. I add the third row, no problems. Then I added the welders to the ends of the pistons. Result - Nothing... for about 2 minutes. Then, without any interaction whatsoever with the pistons or welders (I was hovering above the unit figuring out my next move... and suddenly ... BOOM... Unit explodes at the pistons, launching my sled once again 100's of meters away from the building... only this time it also freezes my game.

    https://steamcommunity.com/sharedfiles/filedetails/?id=1208989829

    [​IMG]

    https://steamcommunity.com/sharedfiles/filedetails/?id=1208989668

    [​IMG]

    https://steamcommunity.com/sharedfiles/filedetails/?id=1208989313

    [​IMG]

    Here is the link to the world file on Steam:
    https://steamcommunity.com/sharedfiles/filedetails/?id=1208995948
     
    • Informative Informative x 2
  2. woodzykiler2

    woodzykiler2 Trainee Engineer

    Messages:
    19
    There is a known with wheels flying off for no reason atm. that is likey the issue you have, Wheels fly off thing get out of line and BOOM
    Also i tryed out your map. and when i rand the printer the wheels went in 2 diffrent directions. Tue reversing 2 of the rotors so it moved in a stright line and now twisting
     
    Last edited: Nov 24, 2017
    • Agree Agree x 2
  3. Buzzed Bear

    Buzzed Bear Apprentice Engineer

    Messages:
    275
    Thanks for the reply - I saw the wheels and fixed them. I played around with the setting in the pistons and It seemed to help. I am sure all of this will be worked out in future updates.
    I still get weird stuff happening - rotors now NEED a lock on them as the braking torque is useless...

    Appreciate your help! Thanks!
     
Thread Status:
This last post in this thread was made more than 31 days old.